Critical, CVSS 9.8PyPIAmendedPublished
Mocodo vulnerable to SQL injection in /web/generate.php
CVE-2024-35374 · GHSA-j6cv-98jx-mrwr
- Affected
- PyPI mocodo <= 4.2.6
- Fixed in
- 4.2.7· Vendor fix available
- Issue
- Mocodo Mocodo Online 4.2.6 and below does not properly sanitize the sqlcase input field in /web/generate.php, allowing remote attackers to execute arbitrary SQL commands and potentially command injection, leading to remote code execution (RCE) under certain conditions.
Recommended action: Upgrade to 4.2.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.