Skip to content

← Public intelligence

PyPI package

mailman

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.6PyPIAmendedPublished

    Mailman Core vulnerable to timing attacks

    CVE-2021-34337 · GHSA-2jg5-xgvv-4wq7

    Affected
    • PyPI mailman < 3.3.5
    Fixed in
    3.3.5· Vendor fix available
    Issue
    An issue was discovered in Mailman Core before 3.3.5. An attacker with access to the REST API could use timing attacks to determine the value of the configured REST API password and then make arbitrary REST API calls. The REST API is bound to localhost by default, limiting the ability for attackers to exploit this, but can optionally be made to listen on other interfaces.

    Recommended action: Upgrade to 3.3.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratedPyPIAmendedPublished

    mailman Cross-site scripting (XSS) vulnerability

    CVE-2004-1177 · GHSA-rh6c-jh4c-9fg3

    Affected
    • PyPI mailman < 2.1.5
    Fixed in
    2.1.5· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

    Recommended action: Upgrade to 2.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. UnratedPyPIAmendedPublished

    Mailman Sensitive Information Disclosure

    CVE-2004-0412 · GHSA-hj4h-vqpq-95wg

    Affected
    • PyPI mailman < 2.1.5
    Fixed in
    2.1.5· Vendor fix available
    Issue
    Mailman before 2.1.5 allows remote attackers to obtain user passwords via a crafted email request to the Mailman server.

    Recommended action: Upgrade to 2.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. UnratedPyPIAmendedPublished

    Mailman Cross-site scripting (XSS) vulnerability

    CVE-2003-0038 · GHSA-82rm-28q9-435p

    Affected
    • PyPI mailman < 2.1.1
    Fixed in
    2.1.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

    Recommended action: Upgrade to 2.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. High, CVSS 8.8PyPIAmendedPublished

    Cross Site Request Forgery in mailman

    CVE-2021-44227 · GHSA-xq58-69h2-765m

    Affected
    • PyPI mailman < 2.1.38
    Fixed in
    2.1.38· Vendor fix available
    Issue
    In GNU Mailman before 2.1.38, a list member or moderator can get a CSRF token and craft an admin request (using that token) to set a new admin password or make other changes.

    Recommended action: Upgrade to 2.1.38 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 6.5PyPIAmendedPublished

    Moderate severity vulnerability that affects mailman

    CVE-2018-13796 · GHSA-xqvg-xm9m-p2c4

    Affected
    • PyPI mailman < 2.1.28
    Fixed in
    2.1.28· Vendor fix available
    Issue
    An issue was discovered in GNU Mailman before 2.1.28. A crafted URL can cause arbitrary text to be displayed on a web page from a trusted site.

    Recommended action: Upgrade to 2.1.28 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →