Skip to content

← Public intelligence

PyPI package

magnum

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3PyPIAmendedPublished

    OpenStack magnum vulnerable to time-of-check to time-of-use (TOCTOU) attack

    CVE-2024-28718 · GHSA-jx7x-9r98-h5xr

    Affected
    • PyPI magnum < 14.1.2; >= 17.0.0.0rc1, < 17.0.2; >= 16.0.0.0rc1, < 16.0.2; >= 15.0.0.0rc1, < 15.0.2
    Fixed in
    16.0.217.0.215.0.214.1.2· Vendor fix available
    Issue
    An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the certmanager.py. component.

    Recommended action: Upgrade to 17.0.2, 16.0.2, 15.0.2 or 14.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →