Skip to content

← Public intelligence

PyPI package

mage-ai

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2PyPIAmendedPublished

    Mage-ai missing user authentication

    CVE-2023-31143 · GHSA-c6mm-2g84-v4m7

    Affected
    • PyPI mage-ai >= 0.8.34, < 0.8.72
    Fixed in
    0.8.72· Vendor fix available
    Issue
    Impact You may be impacted if you're using Mage with user authentication enabled. The terminal could be accessed by users who are not signed in or do not have editor permissions. Patches The vulnerability has been resolved in Mage version 0.8.72.

    Recommended action: Upgrade to 0.8.72 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →