Skip to content

← Public intelligence

PyPI package

llama-index-vector-stores-duckdb

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PyPIAmendedPublished

    LlamaIndex DuckDBVectorStore vulnerable to SQL injection through ref_doc_id

    CVE-2025-1750 · GHSA-6mcc-q3mg-3qg6

    Affected
    • PyPI llama-index-vector-stores-duckdb >= 0.12.19, < 0.12.21
    Fixed in
    0.12.21· Vendor fix available
    Issue
    An SQL injection vulnerability exists in the delete function of DuckDBVectorStore in run-llama/llamaindex version v0.12.19. This vulnerability allows an attacker to manipulate the refdocid parameter, enabling them to read and write arbitrary files on the server, potentially leading to remote code execution (RCE).

    Recommended action: Upgrade to 0.12.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →