Skip to content

← Public intelligence

PyPI package

lightgbm

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PyPIAmendedPublished

    LightGBM Remote Code Execution Vulnerability

    CVE-2024-43598 · GHSA-2586-f3p4-hq84

    Affected
    • PyPI lightgbm >= 1.0.0, < 4.6.0
    Fixed in
    4.6.0· Vendor fix available
    Issue
    LightGBM Remote Code Execution Vulnerability

    Recommended action: Upgrade to 4.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →