Critical, CVSS 9.3PyPIAmendedPublished
libtaxii Server-Side Request Forgery vulnerability
CVE-2020-27197 · GHSA-836c-xg97-8p4h
- Affected
- PyPI libtaxii < 1.1.118
- Fixed in
- 1.1.118· Vendor fix available
- Issue
- "TAXII libtaxii through 1.1.117, as used in EclecticIQ OpenTAXII through 0.2.0 and other products, allows SSRF via an initial http:// substring to the parse method, even when the nonetwork setting is used for the XML parser. NOTE: the vendor points out that the parse method "wraps the lxml library" and that this may be an issue to "raise ... to the lxml group.""
Recommended action: Upgrade to 1.1.118 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.