Skip to content

← Public intelligence

PyPI package

leo

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Regular Expression Denial of Service in Leo Editor

    CVE-2020-23478 · GHSA-x38q-xg2h-rxgx

    Affected
    • PyPI leo <= 6.2.1
    Fixed in
    6.3· Vendor fix available
    Issue
    Leo Editor v6.2.1 was discovered to contain a regular expression denial of service (ReDoS) vulnerability in the component plugins/importers/dart.py.

    Recommended action: Upgrade to 6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →