Skip to content

← Public intelligence

PyPI package

lektor

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    Lektor does not sanitize database path traversal

    CVE-2024-28335 · GHSA-wv28-7fpw-fj49

    Affected
    • PyPI lektor < 3.3.11; >= 3.4.0b1, < 3.4.0b11
    Fixed in
    3.4.0b113.3.11· Vendor fix available
    Issue
    Lektor before 3.3.11 does not sanitize DB path traversal. Thus, shell commands might be executed via a file that is added to the templates directory, if the victim's web browser accesses an untrusted website that uses JavaScript to send requests to localhost port 5000, and the web browser is running on the same machine as the "lektor server" command.

    Recommended action: Upgrade to 3.4.0b11 (pre-release) or 3.3.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →