Skip to content

← Public intelligence

PyPI package

keycloak-httpd-client-install

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8PyPIAmendedPublished

    keycloak-httpd-client-install Insecure Secrets

    CVE-2017-15112 · GHSA-89c9-3758-737w

    Affected
    • PyPI keycloak-httpd-client-install < 0.8
    Fixed in
    0.8· Vendor fix available
    Issue
    keycloak-httpd-client-install versions before 0.8 allow users to insecurely pass password through command line, leaking it via command history and process info to other local users.

    Recommended action: Upgrade to 0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.5PyPIAmendedPublished

    keycloak-httpd-client-install symlink attack vulnerability

    CVE-2017-15111 · GHSA-vqf9-v3hc-wr54

    Affected
    • PyPI keycloak-httpd-client-install < 0.8
    Fixed in
    0.8· Vendor fix available
    Issue
    keycloak-httpd-client-install versions before 0.8 insecurely creates temporary file allowing local attackers to overwrite other files via symbolic link.

    Recommended action: Upgrade to 0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →