Skip to content

← Public intelligence

PyPI package

kallithea

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PyPIAmendedPublished

    RhodeCode and Kallithea are vulnerable to sensitive information disclosure

    CVE-2015-0260 · GHSA-hhx9-4vw2-x54r

    Affected
    • PyPI kallithea < 0.2
    Fixed in
    0.2· Vendor fix available
    Issue
    RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the getrepo API method.

    Recommended action: Upgrade to 0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.1PyPIAmendedPublished

    Kallithea cross-site scripting (XSS) vulnerability

    CVE-2015-1864 · GHSA-fh5c-7gmg-xmp6

    Affected
    • PyPI kallithea < 0.2.1
    Fixed in
    0.2.1· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in the administration pages in Kallithea before 0.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) first name or (2) last name user details, or the (3) repository, (4) repository group, or (5) user group description.

    Recommended action: Upgrade to 0.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.7PyPIAmendedPublished

    Kallithea cross-site request forgery (CSRF) vulnerability

    CVE-2015-0276 · GHSA-6fgp-29mf-chhc

    Affected
    • PyPI kallithea < 0.2
    Fixed in
    0.2· Vendor fix available
    Issue
    Cross-site request forgery (CSRF) vulnerability in Kallithea before 0.2.

    Recommended action: Upgrade to 0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.8PyPIAmendedPublished

    Kallithea Routes CSRF Bypass

    CVE-2016-3691 · GHSA-799h-qr84-pcrp

    Affected
    • PyPI kallithea < 0.3.2
    Fixed in
    0.3.2· Vendor fix available
    Issue
    Routes in Kallithea before 0.3.2 allows remote attackers to bypass the CSRF protection by using the GET HTTP request method.

    Recommended action: Upgrade to 0.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. High, CVSS 8.9PyPIAmendedPublished

    Kallithea CRLF injection vulnerability

    CVE-2015-5285 · GHSA-vfg9-phjp-9frw

    Affected
    • PyPI kallithea < 0.3
    Fixed in
    0.3· Vendor fix available
    Issue
    CRLF injection vulnerability in Kallithea before 0.3 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the camefrom parameter to admin/login.

    Recommended action: Upgrade to 0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →