Skip to content

← Public intelligence

PyPI package

hnswlib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5PyPIAmendedPublished

    hnswlib Double Free vulnerability

    CVE-2023-37365 · GHSA-xwc8-rf6m-xr86

    Affected
    • PyPI hnswlib < 0.8.0
    Fixed in
    0.8.0· Vendor fix available
    Issue
    Hnswlib 0.7.0 has a double free in initindex when the M argument is a large integer.

    Recommended action: Upgrade to 0.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →