Skip to content

← Public intelligence

PyPI package

guardrails-ai

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6PyPIAmendedPublished

    Guardrails has an arbitrary code execution vulnerability

    CVE-2024-45858 · GHSA-w392-75q8-vr67

    Affected
    • PyPI guardrails-ai >= 0.2.9, < 0.5.10
    Fixed in
    0.5.10· Vendor fix available
    Issue
    An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files. If a victim user loads a maliciously crafted XML file containing Python code, the code will be passed to an eval function, causing it to execute on the user's machine.

    Recommended action: Upgrade to 0.5.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.2PyPIAmendedPublished

    Guardrails AI vulnerable to Improper Restriction of XML External Entity Reference

    CVE-2024-6961 · GHSA-f8hx-f4xw-c646

    Affected
    • PyPI guardrails-ai < 0.5.0
    Fixed in
    0.5.0· Vendor fix available
    Issue
    RAIL documents are an XML-based format invented by Guardrails AI to enforce formatting checks on LLM outputs. Guardrails users that consume RAIL documents from external sources are vulnerable to XXE, which may cause leakage of internal file data via the SYSTEM entity.

    Recommended action: Upgrade to 0.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →