Skip to content

← Public intelligence

PyPI package

google-adk

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    Google Agent Development Kit (ADK) has a Code Injection and Missing Authentication vulnerability

    CVE-2026-4810 · GHSA-rg7c-g689-fr3x

    Affected
    • PyPI google-adk >= 2.0.0a1, < 2.0.0a2; >= 1.7.0, < 1.28.1
    Fixed in
    1.28.12.0.0a2· Vendor fix available
    Issue
    A Code Injection and Missing Authentication vulnerability in Google Agent Development Kit (ADK) versions 1.7.0 (and 2.0.0a1) through 1.28.1 (and 2.0.0a2) on Python (OSS), Cloud Run, and GKE allows an unauthenticated remote attacker to execute arbitrary code on the server hosting the ADK instance. This vulnerability was patched in versions 1.28.1 and 2.0.0a2. Customers need to redeploy the upgraded ADK to their production environments. In addition, if they are running ADK Web locally, they also need to upgrade their local instance.

    Recommended action: Upgrade to 2.0.0a2 (pre-release) or 1.28.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →