Skip to content

← Public intelligence

PyPI package

gerapy

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPyPIPublished

    PYSEC-2022-228

    CVE-2021-44597 · GHSA-29vr-79w7-p649

    Affected
    • PyPI gerapy < 0.9.8
    Fixed in
    0.9.8· Vendor fix available
    Issue
    An Access Control vunerabiity exists in Gerapy v 0.9.7 via the spider parameter in project_configure function.

    Recommended action: Upgrade to 0.9.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    An authenticated user can execute arbitrary command in Gerapy

    CVE-2021-32849 · GHSA-756h-r2c9-qp5j

    Affected
    • PyPI gerapy < 0.9.9
    Fixed in
    0.9.9· Vendor fix available
    Issue
    Impact An authenticated user can execute arbitrary command, see more in https://github.com/Gerapy/Gerapy/issues/211. Patches Fixed in 0.9.9

    Recommended action: Upgrade to 0.9.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.3PyPIAmendedPublished

    Gerapy may cause remote code execution

    CVE-2021-43857 · GHSA-9w7f-m4j4-j3xw

    Affected
    • PyPI gerapy < 0.9.8
    Fixed in
    0.9.8· Vendor fix available
    Issue
    Impact projectconfigure function exist remote code execute in Gerapy < 0.9.8 Patches Patched in version 0.9.8, please install with:

    Recommended action: Upgrade to 0.9.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Critical, CVSS 9.3PyPIAmendedPublished

    Command injection in Gerapy

    CVE-2020-7698 · GHSA-g57j-q48p-9vm2

    Affected
    • PyPI gerapy < 0.9.3
    Fixed in
    0.9.3· Vendor fix available
    Issue
    This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the projectconfigure endpoint, isn’t being sanitized.

    Recommended action: Upgrade to 0.9.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →