Skip to content

← Public intelligence

PyPI package

future

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Python Charmers Future denial of service vulnerability

    CVE-2022-40899 · GHSA-v3c5-jqr6-7qm8

    Affected
    • PyPI future <= 0.18.2
    Fixed in
    0.18.3· Vendor fix available
    Issue
    An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.

    Recommended action: Upgrade to 0.18.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →