Medium, CVSS 6.3PyPIAmendedPublished
Flair allows arbitrary code execution
CVE-2024-10073 · GHSA-9rw2-jf8x-cgwm
- Affected
- PyPI flair < 0.15.0
- Fixed in
- 0.15.0· Vendor fix available
- Issue
- A vulnerability, which was classified as critical, was found in flairNLP flair 0.14.0. Affected is the function ClusteringModel of the file flair\models\clustering.py of the component Mode File Loader. The manipulation leads to code injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Recommended action: Upgrade to 0.15.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.