Skip to content

← Public intelligence

PyPI package

ebookmeta

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    ebookmeta XML External Entity vulnerability

    CVE-2024-36827 · GHSA-whf4-fpj8-pgg8

    Affected
    • PyPI ebookmeta < 1.2.8
    Fixed in
    1.2.8· Vendor fix available
    Issue
    An XML External Entity (XXE) vulnerability in the ebookmeta.getmetadata function of ebookmeta before v1.2.8 allows attackers to access sensitive information or cause a Denial of Service (DoS) via crafted XML input.

    Recommended action: Upgrade to 1.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.8PyPIAmendedPublished

    ebookmeta XML External Entity vulnerability

    CVE-2024-37388 · GHSA-hx54-pf28-7xch

    Affected
    • PyPI ebookmeta < 1.2.8
    Fixed in
    1.2.8· Vendor fix available
    Issue
    An XML External Entity (XXE) vulnerability in the ebookmeta.getmetadata function via lxml dependency allows attackers to access sensitive information or cause a Denial of Service (DoS) via crafted XML input.

    Recommended action: Upgrade to 1.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →