High, CVSS 7.5PyPIAmendedPublished
Docassemble unauthorized access through URL manipulation
CVE-2024-27292 · GHSA-jq57-3w7p-vwvv
- Affected
- PyPI docassemble-base >= 1.4.53, < 1.4.97
- Fixed in
- 1.4.97· Vendor fix available
- Issue
- Impact The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. Patches The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched. Workarounds If upgrading is not possible, manually apply the changes of 97f77dc and restart the server. Credit The vulnerability was discovered by Riyush Ghimire (@richighimi). For more information If you have any questions or comments about this advisory: Open an issue in docassemble Join the Slack channel Email us at jhpyle@gmail.com
Recommended action: Upgrade to 1.4.97 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.