Skip to content

← Public intelligence

PyPI package

djblets

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PyPIAmendedPublished

    Djblets Cross-site scripting Vulnerability

    CVE-2014-3995 · GHSA-4xf6-xr96-7vmp

    Affected
    • PyPI djblets < 0.7.30; >= 0.8, < 0.8.3
    Fixed in
    0.8.30.7.30· Vendor fix available
    Issue
    A cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.

    Recommended action: Upgrade to 0.8.3 or 0.7.30 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    Djiblets Cross-site scripting Vulnerability via JSON Objects

    CVE-2014-3994 · GHSA-w7rq-8f2g-jvqr

    Affected
    • PyPI djblets < 0.7.30; >= 0.8, < 0.8.3
    Fixed in
    0.8.30.7.30· Vendor fix available
    Issue
    A cross-site scripting (XSS) vulnerability in util/templatetags/djbletsjs.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django, as used in Review Board, allows remote attackers to inject arbitrary web script or HTML via a JSON object, as demonstrated by the name field when changing a user name.

    Recommended action: Upgrade to 0.8.3 or 0.7.30 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.3PyPIAmendedPublished

    ReviewBoard and Djblets library are vulnerable to code execution

    CVE-2013-4409 · GHSA-58h8-44mg-r43x

    Affected
    • PyPI djblets < 0.6.30; >= 0.7.0, < 0.7.19
    Fixed in
    0.7.190.6.30· Vendor fix available
    Issue
    An eval() vulnerability exists in Python Software Foundation Djblets version before 0.6.30 and 0.7.0 before 0.7.19 and Beanbag Review Board before 1.7.15 when parsing JSON requests allowing an attacker to execute arbitrary Python code.

    Recommended action: Upgrade to 0.7.19 or 0.6.30 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →