High, CVSS 8.7PyPIAmendedPublished
django-mfa2 vulnerable to MFA Replay attack
CVE-2022-42731 · GHSA-vw39-2wj9-4q86
- Affected
- PyPI django-mfa2 < 2.5.1; >= 2.6.0, < 2.6.1
- Fixed in
- 2.5.12.6.1· Vendor fix available
- Issue
- mfa/FIDO2.py in django-mfa2 before 2.5.1 and 2.6.x before 2.6.1 allows a replay attack that could be used to register another device for a user. The device registration challenge is not invalidated after usage.
Recommended action: Upgrade to 2.6.1 or 2.5.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.