High, CVSS 8.7PyPIAmendedPublished
Incorrect Comparison in cvxopt
CVE-2021-41500 · GHSA-8rh6-h94m-vj54
- Affected
- PyPI cvxopt < 1.2.7
- Fixed in
- 1.2.7· Vendor fix available
- Issue
- Incomplete string comparison vulnerability exits in cvxopt.org cvxop <= 1.2.6 in APIs (cvxopt.cholmod.diag, cvxopt.cholmod.getfactor, cvxopt.cholmod.solve, cvxopt.cholmod.spsolve), which allows attackers to conduct Denial of Service attacks by construct fake Capsule objects.
Recommended action: Upgrade to 1.2.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.