Skip to content

← Public intelligence

PyPI package

consoleme

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.6PyPIAmendedPublished

    ConsoleMe has an Arbitrary File Read Vulnerability via Limited Git command

    CVE-2024-5023 · GHSA-3783-62vc-jr7x

    Affected
    • PyPI consoleme < 1.4.0
    Fixed in
    1.4.0· Vendor fix available
    Issue
    ID: NFLX-2024-002 Impact Authenticated users can achieve limited RCE in ConsoleMe, restricted to flag inputs on a single CLI command. Due to this constraint, it is not currently known whether full RCE is possible but it is unlikely. However, a specific flag allows authenticated users to read any server files accessible by the ConsoleMe process. Given ConsoleMe's role as an AWS identity broker, accessing files containing secrets on the server could potentially be exploited for privilege escalation. Deployments of ConsoleMe that allow templated resources are impacted and urged to patch immediately. Deployments that do not permit templated resources are not affected. To determine if your ConsoleMe deployment uses templated resources, check the configuration value for `cache_resource_templates.repositories`. If this value does not exist or is an empty array, your deployment is not impacted. Description The self-service flow for templated resources in ConsoleMe accepts a…

    Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8PyPIAmendedPublished

    Use of Externally-Controlled Format String in consoleme

    CVE-2022-27177 · GHSA-74w3-2r77-fw5h

    Affected
    • PyPI consoleme < 1.2.2
    Fixed in
    1.2.2· Vendor fix available
    Issue
    A Python format string issue leading to information disclosure and potentially remote code execution in ConsoleMe for all versions prior to 1.2.2

    Recommended action: Upgrade to 1.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →