High, CVSS 7.2PyPIAmendedPublished
Composio Eval Injection Vulnerability
CVE-2024-8953 · GHSA-5xg7-5662-8x7j
- Affected
- PyPI composio-core < 0.5.43
- Fixed in
- 0.5.43· Vendor fix available
- Issue
- In composiohq/composio version 0.4.3, the mathematicalcalculator endpoint uses the unsafe eval() function to perform mathematical operations. This can lead to arbitrary code execution if untrusted input is passed to the eval() function.
Recommended action: Upgrade to 0.5.43 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.