High, CVSS 8.7PyPIAmendedPublished
Pylons Colander Denial of Service vulnerability
CVE-2017-18361 · GHSA-rv95-4wxj-6fqq
- Affected
- PyPI colander < 1.7.0
- Fixed in
- 1.7.0· Vendor fix available
- Issue
- In Pylons Colander through 1.6, the URL validator allows an attacker to potentially cause an infinite loop thereby causing a denial of service via an unclosed parenthesis.
Recommended action: Upgrade to 1.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.