Low, CVSS 1.3PyPIAmendedPublished
Cloudtoken Insufficiently Protects Credentials
CVE-2018-13390 · GHSA-4fpg-j5mp-783g
- Affected
- PyPI cloudtoken >= 0.1.1, < 0.1.24
- Fixed in
- 0.1.24· Vendor fix available
- Issue
- Unauthenticated access to cloudtoken daemon on Linux via network from version 0.1.1 before version 0.1.24 allows attackers on the same subnet to gain temporary AWS credentials for the users' roles.
Recommended action: Upgrade to 0.1.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.