Skip to content

← Public intelligence

PyPI package

cleo

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9PyPIAmendedPublished

    cleo is vulnerable to Regular Expression Denial of Service (ReDoS)

    CVE-2022-42966 · GHSA-2p9h-ccw7-33gf

    Affected
    • PyPI cleo >= 1.0.0a1, < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the cleo PyPI package, when an attacker is able to supply arbitrary input to the Table.setrows method.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →