High, CVSS 8.7PyPIAmendedPublished
cfscrape Improper Input Validation vulnerability
CVE-2017-7235 · GHSA-5mc5-5j6c-qmf9
- Affected
- PyPI cfscrape >= 1.6.6, <= 1.7.1
- Fixed in
- 1.8.0· Vendor fix available
- Issue
- An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.