Skip to content

← Public intelligence

PyPI package

brotlicffi

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.2Exploited · CISA KEVPyPIAmendedPublished

    Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

    CVE-2026-111497 · GHSA-9v8h-qqgm-4m35

    Affected
    • PyPI brotlicffi >= 1.0.3, < 1.2.1.0
    Fixed in
    1.2.1.0· Vendor fix available
    Issue
    A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

    Recommended action: Upgrade to 1.2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.