High, CVSS 8.7PyPIAmendedPublished
Improper Certificate Validation in blackduck
CVE-2020-27589 · GHSA-f248-v4qh-x2r6
- Affected
- PyPI blackduck >= 0.0.25, < 0.0.53
- Fixed in
- 0.0.53· Vendor fix available
- Issue
- Synopsys hub-rest-api-python (aka blackduck on PyPI) version 0.0.25 - 0.0.52 does not validate SSL certificates in certain cases.
Recommended action: Upgrade to 0.0.53 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.