UnratedPyPIPublished
PYSEC-2022-214
CVE-2022-33004
- Affected
- PyPI beginner >= 0.0.2, < 0.0.5
- Fixed in
- 0.0.5· Vendor fix available
- Issue
- The Beginner package in PyPI v0.0.2 to v0.0.4 was discovered to contain a code execution backdoor via the request package. This vulnerability allows attackers to access sensitive user information and digital currency keys, as well as escalate privileges.
Recommended action: Upgrade to 0.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.