High, CVSS 8.7PyPIAmendedPublished
Asterix Heap-based Buffer Overflow
CVE-2021-44144 · GHSA-6mmf-v5q7-vw2w
- Affected
- PyPI asterix-decoder < 0.7.2
- Fixed in
- 0.7.2· Vendor fix available
- Issue
- Croatia Control Asterix 2.8.1 has a heap-based buffer over-read, with additional details to be disclosed at a later date.
Recommended action: Upgrade to 0.7.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.