Skip to content

← Public intelligence

PyPI package

apache-libcloud

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Apache Libcloud does not verify SSL certificates for HTTPS connections

    CVE-2010-4340 · GHSA-w3j6-8j34-q43x

    Affected
    • PyPI apache-libcloud < 0.4.0
    Fixed in
    0.4.0· Vendor fix available
    Issue
    libcloud before 0.4.0 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack. This is due to an upstream issue with python's SSL module rather than directly with libcloud.

    Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.9PyPIAmendedPublished

    Apache Libcloud vulnerable to certificate impersonation

    CVE-2012-3446 · GHSA-prcq-52f8-fp44

    Affected
    • PyPI apache-libcloud < 0.11.1
    Fixed in
    0.11.1· Vendor fix available
    Issue
    Apache Libcloud before 0.11.1 uses an incorrect regular expression during verification of whether the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via a crafted certificate.

    Recommended action: Upgrade to 0.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. UnratedPyPIAmendedPublished

    Libcloud does not properly scrub data when destroying a DigitalOcean node

    CVE-2013-6480 · GHSA-g892-9h8m-r69r

    Affected
    • PyPI apache-libcloud >= 0.12.3, <= 0.13.2
    Fixed in
    0.13.3· Vendor fix available
    Issue
    Libcloud 0.12.3 through 0.13.2 does not set the scrubdata parameter for the destroy DigitalOcean API, which allows local users to obtain sensitive information by leveraging a new VM.

    Recommended action: Upgrade to 0.13.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →