Skip to content

← Public intelligence

PyPI package

apache-gravitino

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5PyPIPublished

    PYSEC-2026-3442

    CVE-2026-49876

    Affected
    • PyPI apache-gravitino >= 1.0.0, < 1.3.0
    Fixed in
    1.3.0· Vendor fix available
    Issue
    Authenticated SSRF in Gravitino JobManager allows server-side HTTP requests to internal network and cloud metadata endpoints via unvalidated job template URIs. A vulnerability in Apache Gravitino. This issue affects Apache Gravitino: from 1.0.0 through 1.2.1. Users are recommended to upgrade to version 1.3.0, which fixes the issue.

    Recommended action: Upgrade to 1.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. Critical, CVSS 9.1PyPIPublished

    PYSEC-2026-3441

    CVE-2026-41041

    Affected
    • PyPI apache-gravitino >= 1.0.0, < 1.2.1
    Fixed in
    1.2.1· Vendor fix available
    Issue
    URL path injection via unencoded user-supplied identifiers vulnerability in Apache Gravitino. This issue affects Apache Gravitino: from 1.0.0 before 1.2.1. Users are recommended to upgrade to version 1.2.1, which fixes the issue.

    Recommended action: Upgrade to 1.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →