Skip to content

← Public intelligence

PyPI package

apache-dolphinscheduler

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIAmendedPublished

    Apache DolphinScheduler sensitive information disclosure

    CVE-2023-48796 · GHSA-4vvc-r4p4-qgrr

    Affected
    • PyPI apache-dolphinscheduler >= 3.0.0, < 3.0.2
    Fixed in
    3.0.2· Vendor fix available
    Issue
    Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler. The information exposed to unauthorized actors may include sensitive data such as database credentials. Users who can't upgrade to the fixed version can also set environment variable MANAGEMENTENDPOINTSWEBEXPOSUREINCLUDE=health,metrics,prometheus to workaround this, or add the following section in the application.yaml file This issue affects Apache DolphinScheduler: from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.

    Recommended action: Upgrade to 3.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    Apache DolphinScheduler vulnerable to Improper Input Validation

    CVE-2022-45875 · GHSA-3xh5-8hvq-rc8x

    Affected
    • PyPI apache-dolphinscheduler < 3.0.2
    Fixed in
    3.0.2· Vendor fix available
    Issue
    Apache DolphinScheduler improperly validates script alert plugin parameters and is vulnerable to remote command execution. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. Users should upgrade to version 3.0.2 or 3.1.1.

    Recommended action: Upgrade to 3.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5PyPIAmendedPublished

    Uncontrolled Resource Consumption in Apache DolphinScheduler

    CVE-2022-25598 · GHSA-qg5x-66hp-cw5p

    Affected
    • PyPI apache-dolphinscheduler < 2.0.5
    Fixed in
    2.0.5· Vendor fix available
    Issue
    Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks. Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.

    Recommended action: Upgrade to 2.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →