Medium, CVSS 5.9PyPIAmendedPublished
Apache Bookkeeper vulnerable to Improper Certificate Validation
CVE-2022-32531 · GHSA-gxq5-79m2-gvvq
- Affected
- PyPI apache-bookkeeper-client < 4.14.6
- Fixed in
- 4.14.6· Vendor fix available
- Issue
- The Apache Bookkeeper Java Client (before 4.14.6 and also 4.15.0) does not close the connection to the bookkeeper server when TLS hostname verification fails. This leaves the bookkeeper client vulnerable to a man in the middle attack. The problem affects BookKeeper client prior to versions 4.14.6 and 4.15.1.
Recommended action: Upgrade to 4.14.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.