Skip to content

← Public intelligence

PyPI package

apache-airflow

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

153 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Cross-Site Request Forgery (CSRF) in Apache Airflow

    CVE-2017-17835 · GHSA-68wv-rjrm-576p

    Affected
    • PyPI apache-airflow <= 1.8.2
    Fixed in
    1.9.0· Vendor fix available
    Issue
    In Apache Airflow 1.8.2 and earlier, a CSRF vulnerability allowed for a remote command injection on a default install of Airflow.

    Recommended action: Upgrade to 1.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    Apache Airflow vulnerable to XSS

    CVE-2017-17836 · GHSA-9gqg-3fxr-9hv7

    Affected
    • PyPI apache-airflow <= 1.8.2
    Fixed in
    1.9.0· Vendor fix available
    Issue
    In Apache Airflow 1.8.2 and earlier, an experimental Airflow feature displayed authenticated cookies, as well as passwords to databases used by Airflow. An attacker who has limited access to airflow, weather it be via XSS or by leaving a machine unlocked can exfil all credentials from the system.

    Recommended action: Upgrade to 1.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.7PyPIAmendedPublished

    Improper Input Validation in Apache Airflow resulting in Remote Code Execution

    CVE-2017-15720 · GHSA-8fg4-j562-mjrc

    Affected
    • PyPI apache-airflow <= 1.8.2
    Fixed in
    1.9.0· Vendor fix available
    Issue
    In Apache Airflow 1.8.2 and earlier, an authenticated user can execute code remotely on the Airflow webserver by creating a special object.

    Recommended action: Upgrade to 1.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →