High, CVSS 7.5PyPIAmendedPublished
Apache Airflow Celery provider Insertion of Sensitive Information into Log File vulnerability
CVE-2023-46215 · GHSA-666g-rfc5-c9jv
- Affected
- PyPI apache-airflow-providers-celery >= 3.3.0, < 3.4.1
- Fixed in
- 3.4.1· Vendor fix available
- Issue
- Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow. Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend Note: the vulnerability is about the information exposed in the logs not about accessing the logs. This issue affects Apache Airflow Celery provider: from 3.3.0 through 3.4.0; Apache Airflow: from 1.10.0 through 2.6.3. Users are recommended to upgrade Airflow Celery provider to version 3.4.1 and Apache Airlfow to version 2.7.0 which fixes the issue.
Recommended action: Upgrade to 3.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.