Skip to content

← Public intelligence

PyPI package

ansible-runner

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.5PyPIAmendedPublished

    ansible-runner vulnerable to shell command injection

    CVE-2021-4041 · GHSA-6j58-grhv-2769

    Affected
    • PyPI ansible-runner < 2.1.0
    Fixed in
    2.1.0· Vendor fix available
    Issue
    A flaw was found in ansible-runner. An improper escaping of the shell command, while calling the ansiblerunner.interface.runcommand, can lead to parameters getting executed as host's shell command. A developer could unintentionally write code that gets executed in the host rather than the virtual environment.

    Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    ansible-runner vulnerable to Race Condition

    CVE-2021-3702 · GHSA-772j-xvf9-qpf5

    Affected
    • PyPI ansible-runner >= 2.0.0, < 2.1.0
    Fixed in
    2.1.0· Vendor fix available
    Issue
    A race condition flaw was found in ansible-runner, where an attacker could watch for rapid creation and deletion of a temporary directory, substitute their directory at that name, and then have access to ansible-runner's privatedatadir the next time ansible-runner made use of the privatedatadir. The highest Threat out of this flaw is to integrity and confidentiality.

    Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.8PyPIAmendedPublished

    ansible-runner has default temporary files written to world R/W locations

    CVE-2021-3701 · GHSA-wwch-cmqr-hhrm

    Affected
    • PyPI ansible-runner >= 2.0.0, < 2.1.0
    Fixed in
    2.1.0· Vendor fix available
    Issue
    A flaw was found in ansible-runner where the default temporary files configuration in ansible-2.0.0 are written to world R/W locations. This flaw allows an attacker to pre-create the directory, resulting in reading private information or forcing ansible-runner to write files as the legitimate user in a place they did not expect. The highest threat from this vulnerability is to confidentiality and integrity.

    Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →