Skip to content

← Public intelligence

PyPI package

anki

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.0PyPIAmendedPublished

    Anki Latex Incomplete Blocklist Vulnerability

    CVE-2024-29073 · GHSA-x3r6-ccvq-cf5v

    Affected
    • PyPI anki < 24.6
    Fixed in
    24.6· Vendor fix available
    Issue
    An vulnerability in the handling of Latex exists in Ankitects Anki 24.04. When Latex is sanitized to prevent unsafe commands, the verbatim package, which comes installed by default in many Latex distributions, has been overlooked. A specially crafted flashcard can lead to an arbitrary file read. An attacker can share a flashcard to trigger this vulnerability.

    Recommended action: Upgrade to 24.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.6PyPIAmendedPublished

    Ankitects Anki arbitrary script execution vulnerability

    CVE-2024-26020 · GHSA-9gq7-p5w9-w899

    Affected
    • PyPI anki < 24.6
    Fixed in
    24.6· Vendor fix available
    Issue
    An arbitrary script execution vulnerability exists in the MPV functionality of Ankitects Anki 24.04. A specially crafted flashcard can lead to a arbitrary code execution. An attacker can send malicious flashcard to trigger this vulnerability.

    Recommended action: Upgrade to 24.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Low, CVSS 2.3PyPIAmendedPublished

    Ankitects Anki LaTeX Blocklist Bypass vulnerability

    CVE-2024-32152 · GHSA-q47p-v5rw-v574

    Affected
    • PyPI anki < 24.6
    Fixed in
    24.6· Vendor fix available
    Issue
    A blocklist bypass vulnerability exists in the LaTeX functionality of Ankitects Anki 24.04. A specially crafted malicious flashcard can lead to an arbitrary file creation at a fixed path. An attacker can share a malicious flashcard to trigger this vulnerability.

    Recommended action: Upgrade to 24.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →