Skip to content

← Public intelligence

PyPI package

ajenti

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1PyPIAmendedPublished

    Ajenti Cross-site scripting (XSS) vulnerability

    CVE-2014-2260 · GHSA-9crx-p357-5vw8

    Affected
    • PyPI ajenti < 1.2.15
    Fixed in
    1.2.15· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in plugins/main/content/js/ajenti.coffee in Ajenti before 1.2.15 allows remote authenticated users to inject arbitrary web script or HTML via the command field in the Cron functionality.

    Recommended action: Upgrade to 1.2.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.9PyPIAmendedPublished

    Eugene Pankov Ajenti Cross-site scripting Vulnerabilities

    CVE-2014-4301 · GHSA-2ch8-f849-pjg3

    Affected
    • PyPI ajenti < 1.2.21.7
    Fixed in
    1.2.21.7· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in the responderror function in routing.py in Eugene Pankov Ajenti before 1.2.21.7 allow remote attackers to inject arbitrary web script or HTML via the PATHINFO to (1) resources.js or (2) resources.css in ajenti:static/, related to the traceback page.

    Recommended action: Upgrade to 1.2.21.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →