Skip to content

← Public intelligence

PyPI package

admesh

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8PyPIPublished

    PYSEC-2026-5

    CVE-2026-2653

    Affected
    • PyPI admesh < 0.98.6
    Fixed in
    0.98.6· Vendor fix available
    Issue
    A security flaw has been discovered in admesh up to 0.98.5. This issue affects the function stl_check_normal_vector of the file src/normals.c. Performing a manipulation results in heap-based buffer overflow. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. It looks like this product is not really maintained anymore.

    Recommended action: Upgrade to 0.98.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. High, CVSS 8.8PyPIAmendedPublished

    ADMesh improper array index validation

    CVE-2022-38072 · GHSA-v5hv-4pw3-q6h9

    Affected
    • PyPI admesh < 0.98.5
    Fixed in
    0.98.5· Vendor fix available
    Issue
    An improper array index validation vulnerability exists in the stlfixnormaldirections functionality of ADMesh Master Commit 767a105 and v0.98.4. A specially-crafted stl file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

    Recommended action: Upgrade to 0.98.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.1PyPIAmendedPublished

    Out-of-bounds read in admesh

    CVE-2018-25033 · GHSA-5jrq-582v-9767

    Affected
    • PyPI admesh < 0.98.5
    Fixed in
    0.98.5· Vendor fix available
    Issue
    ADMesh through 0.98.4 has a heap-based buffer over-read in stlupdateconnectsremove1 (called from stlremovedegenerate) in connect.c in libadmesh.a.

    Recommended action: Upgrade to 0.98.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →