Skip to content

← Public intelligence

RubyGems package

webrick

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5RubyGemsPublished

    Ruby WEBrick read_headers method can lead to HTTP Request/Response Smuggling

    CVE-2025-6442 · GHSA-r995-q44h-hr64

    Affected
    • RubyGems webrick < 1.8.2
    Fixed in
    1.8.2· Vendor fix available
    Issue
    Ruby WEBrick readheader HTTP Request Smuggling Vulnerability. This vulnerability allows remote attackers to smuggle arbitrary HTTP requests on affected installations of Ruby WEBrick. This issue is exploitable when the product is deployed behind an HTTP proxy that fulfills specific conditions. The specific flaw exists within the readheaders method. The issue results from the inconsistent parsing of terminators of HTTP headers. An attacker can leverage this vulnerability to smuggle arbitrary HTTP requests. Was ZDI-CAN-21876.

    Recommended action: Upgrade to 1.8.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5RubyGemsPublished

    HTTP Request Smuggling in ruby webrick

    CVE-2024-47220 · GHSA-6f62-3596-g6w7

    Affected
    • RubyGems webrick <= 1.8.1
    Fixed in
    1.8.2· Vendor fix available
    Issue
    An issue was discovered in the WEBrick toolkit through 1.8.1 for Ruby. It allows HTTP request smuggling by providing both a Content-Length header and a Transfer-Encoding header, e.g., "GET /admin HTTP/1.1\r\n" inside of a "POST /user HTTP/1.1\r\n" request. NOTE: the supplier's position is "Webrick should not be used in production."

    Recommended action: Upgrade to 1.8.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5RubyGemsPublished

    WEBRick vulnerable to HTTP Request/Response Smuggling

    CVE-2020-25613 · GHSA-gwfg-cqmg-cf8f

    Affected
    • RubyGems webrick >= 1.6.0, <= 1.6.0; >= 1.5.0, <= 1.5.0; < 1.4.4
    Fixed in
    1.6.11.5.11.4.4· Vendor fix available
    Issue
    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    Recommended action: Upgrade to 1.6.1, 1.5.1 or 1.4.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8RubyGemsPublished

    WEBrick RCE Vulnerability

    CVE-2017-10784 · GHSA-369m-2gv6-mw28

    Affected
    • RubyGems webrick < 1.4.0
    Fixed in
    1.4.0· Vendor fix available
    Issue
    The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.

    Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. UnratedRubyGemsPublished

    WEBrick Denial of Service Vulnerability

    CVE-2008-4310 · GHSA-wfrc-r6c6-7j9r

    Affected
    • RubyGems webrick < 1.3.1
    Fixed in
    1.3.1· Vendor fix available
    Issue
    httputils.rb in WEBrick in Ruby 1.8.1 and 1.8.5, as used in Red Hat Enterprise Linux 4 and 5, allows remote attackers to cause a denial of service (CPU consumption) via a crafted HTTP request. NOTE: this issue exists because of an incomplete fix for CVE-2008-3656.

    Recommended action: Upgrade to 1.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. UnratedRubyGemsPublished

    WEBrick Improper Input Validation vulnerability

    CVE-2009-4492 · GHSA-6mq2-37j5-w6r6

    Affected
    • RubyGems webrick <= 1.3.1
    Fixed in
    1.4.0· Vendor fix available
    Issue
    WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

    Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →