Skip to content

← Public intelligence

RubyGems package

uglifier

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsAmendedPublished

    Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js

    CVE-2015-8857 · GHSA-34r7-q49f-h37c

    Affected
    • RubyGems uglifier < 2.7.2
    Fixed in
    2.7.2· Vendor fix available
    Issue
    Versions of uglify-js prior to 2.4.24 are affected by a vulnerability which may cause crafted JavaScript to have altered functionality after minification. Recommendation Upgrade UglifyJS to version = 2.4.24.

    Recommended action: Upgrade to 2.7.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →