Medium, CVSS 6.1RubyGemsPublished
text_helpers uses web link to untrusted target with window.opener access
CVE-2020-36624 · GHSA-74hc-57m5-83ch
- Affected
- RubyGems text_helpers >= 1.1.0, < 1.2.0
- Fixed in
- 1.2.0· Vendor fix available
- Issue
- A vulnerability was found in ahorner text-helpers 1.1.0/1.1.1. This vulnerability affects unknown code of the file lib/texthelpers/translation.rb. The manipulation of the argument link leads to use of web link to untrusted target with window.opener access. The attack can be initiated remotely. Upgrading to version 1.2.0 can address this issue. The name of the patch is 184b60ded0e43c985788582aca2d1e746f9405a3. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216520.
Recommended action: Upgrade to 1.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.