Skip to content

← Public intelligence

RubyGems package

sup

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedRubyGemsPublished

    Sup Code Injection vulnerability

    CVE-2013-4478 · GHSA-5f2p-6vjv-2q2m

    Affected
    • RubyGems sup < 0.13.2.1; >= 0.14.0, < 0.14.1.1
    Fixed in
    0.14.1.10.13.2.1· Vendor fix available
    Issue
    Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename of an email attachment.

    Recommended action: Upgrade to 0.14.1.1 or 0.13.2.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    Sup Code Injection vulnerability

    CVE-2013-4479 · GHSA-hh2x-7mf9-78fr

    Affected
    • RubyGems sup < 0.13.2.1; >= 0.14.0, < 0.14.1.1
    Fixed in
    0.14.1.10.13.2.1· Vendor fix available
    Issue
    lib/sup/messagechunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the contenttype of an email attachment.

    Recommended action: Upgrade to 0.14.1.1 or 0.13.2.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →