Skip to content

← Public intelligence

RubyGems package

smart_proxy_dynflow

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsPublished

    smart_proxy_dynflow gem authentication bypass in Foreman remote execution feature

    CVE-2018-14643 · GHSA-gx5g-xcxj-cx2w

    Affected
    • RubyGems smart_proxy_dynflow >= 0.2.0, <= 0.2.0; < 0.1.11
    Fixed in
    0.1.110.2.1· Vendor fix available
    Issue
    An authentication bypass flaw was found in the smartproxydynflow component used by Foreman. A malicious attacker can use this flaw to remotely execute arbitrary commands on machines managed by vulnerable Foreman instances, in a highly privileged context.

    Recommended action: Upgrade to 0.2.1 or 0.1.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →