Skip to content

← Public intelligence

RubyGems package

safemode

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1RubyGemsPublished

    safemode gem allows context-dependent attackers to obtain sensitive information via the inspect method

    CVE-2016-3693 · GHSA-c92m-rrrc-q5wf

    Affected
    • RubyGems safemode < 1.2.4
    Fixed in
    1.2.4· Vendor fix available
    Issue
    The Safemode gem before 1.2.4 for Ruby, when initialized with a delegate object that is a Rails controller, allows context-dependent attackers to obtain sensitive information via the inspect method.

    Recommended action: Upgrade to 1.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8RubyGemsPublished

    Safemode Gem Has Incomplete List of Disallowed Inputs

    CVE-2017-7540 · GHSA-5vx5-9q73-wgp4

    Affected
    • RubyGems safemode < 1.3.2
    Fixed in
    1.3.2· Vendor fix available
    Issue
    rubygem-safemode, as used in Foreman, versions 1.3.1 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.

    Recommended action: Upgrade to 1.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →