Low, CVSS 3.3RubyGemsPublished
RuboCop gem Insecure use of /tmp
CVE-2017-8418 · GHSA-wmjf-jpjj-9f3j
- Affected
- RubyGems rubocop < 0.49.0
- Fixed in
- 0.49.0· Vendor fix available
- Issue
- RuboCop 0.48.1 and earlier does not use /tmp in safe way, allowing local users to exploit this to tamper with cache files belonging to other users.
Recommended action: Upgrade to 0.49.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.