Skip to content

← Public intelligence

RubyGems package

rotp

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3RubyGemsPublished

    ROTP 6.2.2 and 6.2.1 has 0666 permissions for the .rb files.

    CVE-2024-28862 · GHSA-x2h8-qmj4-g62f

    Affected
    • RubyGems rotp >= 6.2.1, < 6.3.0
    Fixed in
    6.3.0· Vendor fix available
    Issue
    The Ruby One Time Password library (ROTP) is an open source library for generating and validating one time passwords. Affected versions had overly permissive default permissions. Users should patch to version 6.3.0. Users unable to patch may correct file permissions after installation.

    Recommended action: Upgrade to 6.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →